When sending an Outreach, Admins have the option to log emails to Salesforce. The sent email will then display as a record in the contact’s Activity History in Salesforce. After selecting this option and sending the Outreach, you may encounter an Outreach failure.

Below illustrates where to select this checkbox when editing the Journey Orchestrator Outreach:

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Cause

This most often occurs when the OAuth user (who authorizes MDA) does not have permission to the “View All Data” permission set. This permission is necessary because the OAuth user will be used to write this data to the Activity History related list in Salesforce. This list pulls from multiple objects, and the user will need access to view data within those objects.

Resolution

To add this permission set for the OAuth user, complete the following steps:

  1. After identifying the OAuth User, navigate to Setup > Manage Users >Users
  2. In the list of Users, locate the name of the OAuth user, and click their name.
  3. Locate the listed Profile for the user and click the name of this profile.
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  1. Click to edit the profile.
  2. Navigate to the Administrative Permissions section.
  3. Locate the option for ‘View All Data’ and check this box.
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  1. Save the Profile.